'ERROR:=0AORA-01017: Invalid username/password; logon denied=0A=0A' when running a CCS data collection on Oracle assets
search cancel

'ERROR:=0AORA-01017: Invalid username/password; logon denied=0A=0A' when running a CCS data collection on Oracle assets

book

Article ID: 243198

calendar_today

Updated On:

Products

Control Compliance Suite Standards Server Control Compliance Suite

Issue/Introduction

In Control Compliance Suite during a data collection or CER job for an Oracle Agent-based asset, you see the following error 

“Failure occurred in query execution.  ERROR:=0AORA-01017: Invalid username/password; logon denied=0A=0A=oASP2-0751: Unable to connect to Oracle.  Exiting SQL*Plus-0A=0A.”

OR

Failure occurred in query execution. ERROR:=0AORA-28000: The account is locked.=0A=0A=0ASP2-0751: Unable to connect to Oracle.  Exiting SQL*Plus=0A=0A. Scope is database 'DBName' on server 'AssetName'

Cause

This happens when using local credentials such as the CCSDBA/C##CCSDBA user account for the Oracle data collection.

The Oracle asset is set up to use ServiceName in CCS.

You run the ccsorasetup utility with the '-s DBNAME' option, but then go back and run it again with the '-a all' option.

The second option configures the database as SID and creates a new .dat file with the new password while the old .dat file for Service does not get updated.

Resolution

On the Agent that is reporting this issue re-run the ccsorasetup utility.

ccsorasetup -s DBNAME

Where the DBNAME is the database asset that is reporting the invalid username/password in the CCS Console.