Unspecified error=0D=0A when running Oracle Data Collection in CCS
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Unspecified error=0D=0A when running Oracle Data Collection in CCS

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Article ID: 243197

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Updated On:

Products

Control Compliance Suite Standards Server

Issue/Introduction

Control Compliance Suite (CCS)

When running a data collection or CER job for Oracle on an Agent-based asset results in the following error:

Unspecified error=0D=0A error message.

Environment

CCS 12.6.x

Cause

This is a general error and can by caused by a number of things. 

In this case, the reason for the Unspecified error is that the local database credential does not exist.

Resolution

Agent-based data collection:

On the CCS Agent run the 'ccsorasetup' tool to configure local credentials using either '-a' option to configure using SID, or the '-s' option to configure Service Name.

Depending on how the CCS Asset is configured.

As per the documentation, the Service Name should be used.

"If the Oracle Service name and the Oracle SID name are same, you can scan the agent-based asset with database name type as Service Name only.
Also, you must manually change the database name type from SID to Service Name after the agent-based asset is imported to Control Compliance Suite."

Data collection support for agent-based Oracle assets

Agent-less data collection:

Make sure that the Oracle asset has all the attributes filled out, especially the Operating System field. This will cause this error, as CCS is not able to identify the OS.
Once that is set the issue will no longer occur.