PCs with multiple network adapters cannot connect to the scalability server
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PCs with multiple network adapters cannot connect to the scalability server

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Article ID: 243116

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Updated On: 10-09-2023

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

Computer connected with Cisco AnyConnect and with multiple network adapters cannot communicate with the scalablity servers.

Environment

Client Automation - All Versions

Cause

CAM is using the first ipaddress returned by command ipconfig /all
If first ipaddress is not the ipaddress to use for client automation communication, there is a communication problem.
 
Example :
In ipconfig /all following network adapters are found in this order
 
 
   Description . . . . . . . . . . . : Intel(R) Wi-Fi 6 AX201 160MHz
 IPv4 Address. . . . . . . . . . . : 192.0.2.165(Preferred)

   Description . . . . . . . . . . . : Cisco AnyConnect Secure Mobility Client Virtual Miniport Adapter for Windows x64
 IPv4 Address. . . . . . . . . . . : 10.a.b.c(Preferred) 


CAM is using first IPAddress found (192.0.2.165). It is not the correct IP Address as it should use the Cisco ipaddress 10.*
CAM could not communicate with the scalability server

Resolution

Here is a solution based on a dms script (update_cam.cfg.dms) which updates dynamically the file cam.cfg with valid IP Address found in ipconfig /all command.
 
The solution is :
 
1- Copy the file update_cam.cfg.dms on the Agents under C:\Program Files (x86)\CA\DSM\Bin
 
This could be done with a SD Package for example
 
 
2- Update the configuration policy applied on the computers with this :
 
DSM/Common Components/CAF/General/CAF: Startup script = dmscript update_cam.cfg.dms
DSM/Common Components/CAF/General/CAF: Address change command = dmscript update_cam.cfg.dms
 
Everytime caf is started or ipaddress list is changed, the script update_cam.cfg.dms is executed
 
 
 
The script works like this :
 
- It executes "ipconfig /all" to find the list of all ipaddress
- If only 1 ipaddress is found, nothing is done.
- If first IPaddress is like 10.* nothing is done.
- If one IPAddress like 10.* is found in the list, then cam.cfg is updated with this ipaddress.
 
 

Additional Information

This script generates a log under DSM\logs\update_cam.cfg.log

 

-----------------------------------------------------------------
06/03/2022 17:57:33 - START update_cam.cfg.dms
06/03/2022 17:57:33 - Computer = JY-2019-145
06/03/2022 17:57:33 - User = Administrator
06/03/2022 17:57:33 - Version = 1.1
06/03/2022 17:57:33 - ITCM Log Path = C:\Program Files (x86)\CA\DSM\\logs\
06/03/2022 17:57:33 - CAM Path = C:\Program Files (x86)\CA\SC\CAM
06/03/2022 17:57:33 - Execute: cmd /C ipconfig /all > "C:\Users\ADMINI~1\AppData\Local\Temp\ipconfig.tmp"
06/03/2022 17:57:34 - Find 1 IP Address
06/03/2022 17:57:34 -    192.0.2.177
06/03/2022 17:57:34 - Only 1 IP Address. Nothing to do
-----------------------------------------------------------------

Attachments

1654271382949__update_cam.cfg.dms get_app