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E03020054 The package is being used by another process

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Article ID: 243047

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Updated On:

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CA Harvest Software Change Manager

Issue/Introduction

This happens on occasion, but the frequency has increased since our team has been working remotely. From time to time after a checkin process for a file completes, the harpackage status field does not update to "Idle", but rather keeps the value "Checkin". This happens over multiple environments/projects, and there are no UDPs assigned to some of those checkin processes. Here is an example of the output messages and what is going on:
 
I00020110: File <filename>;35 checked out to <filename>.
I00060080: Check out summary: Total: 1; Success: 1; Failed: 0; Not Processed: 0.
---------- End  <Check Out for Update>  Process ---------------
 
---------- Begin  <Check In Items>  Process ---------------
I00020100: File <filename> checked into <filename>;36.
I00060079: Check in summary: Total: 1; Success: 1; Failed: 0; Not Processed: 0.
---------- End  <Check In Items>  Process ---------------
 
---------- Begin  <Promote to Released>  Process ---------------
E03020054: The package named <packagename> is being used by Checkin. Client: /pt_HClient://<clienthost>/<clientpid> Server: /pt_HServer://<hserverhost>/<hserverpid>
E03020141: Promote aborted; could not change package status.
E03060019: Process Execute failed. Process Name: Promote to Released.
---------- End  <Promote to Released>  Process ---------------
 
Due to the increased frequency after teleworking, my gut says it has something to do with that...perhaps bad connections, who knows. It also seems to be happening to the same handful of people each time.

Cause

Found 2 examples of the error:
Search "HSRV_E_CHANGE_PKG_STATUS" (2 hits in 2 files of 9 searched)
  20211207HServer55695.log (1 hit)
                Line 648787: -- SEND ERROR:   HSRV_E_CHANGE_PKG_STATUS Promote  
  20211207HServer55778.log (1 hit)
                Line 660853: -- SEND ERROR:   HSRV_E_CHANGE_PKG_STATUS Promote  

In the first case, tracing back what happens with that package just before the error I’m seeing a checkin process that hit a problem:

In 20211207HServer55599.log starting line 642112:
-- SEND MESSAGE:   HSRV_I_CHECKIN <filename> <filename>;25 

-- START: 2021/12/07 14:49:32 DB Connect#: 4991  SINCE LAST SQL: 0 

   COMMIT

-- END:  2021/12/07 14:49:32    **** SQL Milliseconds: 0  

-- SEND INFO MESSAGE:   HSRV_I_CHECKIN_STATUS 1 1 0
-- SEND STATUS:  END 

-- HServer Disconnected from the Data Source
HServer | 20211207 14:49:33 | is shutting down <Memory threshold reached> ****

-- Catch Error:   HSRV_E_DB   

-- HServer Disconnected from the Data Source

-- SINCE LAST SQL: 372
2021/12/07 14:49:33 | End   EXECUTE_CHECKIN 372  TRANSACTION TIME: 2093525824

The HServer crashed because of a memory issue.  

Environment

Release : 14.0

Component : CA HARVEST SCM CORE FUNCTIONALITY/PROCESS AUTOMATION

Resolution

Tried using the HServer.arg's "-memorylimit=" option to increase the memory limit but this did not resolve the problem.

An EFix was provided.  If you see the same problem, please contact support.