search cancel

Is cabi 4.3 compatibile with TLS 1.2 and SLQServer 2016?

book

Article ID: 243001

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Is the combination of TLS 1.2 + cabi 4.3 + SQLServer 2016 supported? We are unable to install cabi in this combination. The Operating Systems is Windows 2016 as well. 

Environment

Release : 20.3/20.4

Component :UIM cabi

Resolution

CABI 4.3 (shipped with UIM 20.3) and CABI 7.5 (shipped with UIM 20.4) are bundled with Jasper Reports Server (JRS) 7.5. These CABI versions are compatible with TLS 1.2 and SQL Server 2014, 2016 and 2017. However this combination is not supported if SQL Server is installed on Windows Server 2016 Operating System.

As per the compatibility matrix from Microsoft, SQL Server 2016 SP2 or later update is compatible with Windows 2019 OS. So, CABI 7.5 with SQL Server 2016 SP2 (or later update) on Windows 2019 should work.

Additional Information

For more details on the SQL Server version requirements, please refer to this doc -

 https://docs.microsoft.com/en-us/troubleshoot/sql/general/use-sql-server-in-windows#minimum-sql-server-version-requirements-for-windows-server-2019