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data_engine queue backed up for Oracle 19c backend database

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Article ID: 242972

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM) Unified Infrastructure Management for Mainframe

Issue/Introduction

During a webex for discussion of upgrade plans, we noticed that the data_engine queue was very backed up.

Cause

- Oracle LOCK/UNLOCK errors/issues

Environment

  • Release : UIM 20.3 or higher
  • Component : data_engine v20.31 or higher
  • Oracle 19c database

Resolution

  1. Deactivate data_engine
  2. Set loglevel to 3, logsize to 50000
  3. Change thread_count_insert from 2 to 24.
  4. Activate data_engine
  5. Check the data_engine startup process via the log.
  6. Checked the hub Status view in IM and the queue was processing very efficiently, e.g., ~18,000 messages per min.