data_engine queue backed up for Oracle 19c backend database
book
Article ID: 242972
calendar_today
Updated On:
Products
DX Unified Infrastructure Management (Nimsoft / UIM)
CA Unified Infrastructure Management On-Premise (Nimsoft / UIM)
CA Unified Infrastructure Management SaaS (Nimsoft / UIM)
Unified Infrastructure Management for Mainframe
Issue/Introduction
During a webex for discussion of upgrade plans, we noticed that the data_engine queue was very backed up.
Environment
- Release : UIM 20.3 or higher
- Component : data_engine v20.31 or higher
- Oracle 19c database
Cause
- Oracle LOCK/UNLOCK errors/issues
Resolution
- Deactivate data_engine
- Set loglevel to 3, logsize to 50000
- Change thread_count_insert from 2 to 24.
- Activate data_engine
- Check the data_engine startup process via the log.
- Checked the hub Status view in IM and the queue was processing very efficiently, e.g., ~18,000 messages per min.
Feedback
thumb_up
Yes
thumb_down
No