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Imported PAC file changes trigger errors with PFMS and cannot save

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Article ID: 242934

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Updated On:

Products

Web Security Service - WSS

Issue/Introduction

PAC pushed down to corporate users hosted on an on premise Web server.

Exported this locally hosted PAC file and imported it into WSS Portal PFMS setup.

After importing into WSS Portal, the PAC file cannot save, returning a "Too many errors" message visible on Portal (yellow highlight below)

PAC file passes PAC file validation using multiple tools, including https://thorsen.pm/proxyforurl

 

Cause

Defect with PAC file validator used by WSS

Resolution

Fixed in updated Portal.

As a workaround to the issue, we took each individual 'if' conditional statement (there we 50-60) and merged them all into one conditional statement. After making these changes, the save succeeded without errors.

An example of the workaround was to take the following four individual entries:

 if (dnsDomainIs(host, "0APP0040.tulip.local")) {return "DIRECT";}
 if (dnsDomainIs(host, "0APP0041.tulip.local")) {return "DIRECT";}
 if (dnsDomainIs(host, "0APP0042.tulip.local")) {return "DIRECT";}
 if (dnsDomainIs(host, "0APP0043.tulip.local")) {return "DIRECT";}

and replaced it with one:
 
 if (dnsDomainIs(host, "0APP0040.tulip.local") ||
  dnsDomainIs(host, "0APP0041.tulip.local") ||
  dnsDomainIs(host, "0APP0042.tulip.local") ||
  dnsDomainIs(host, "0APP0043.tulip.local"))
 {return "DIRECT";}