search cancel

DevTest Portal is no longer showing any Virtual Services after deploying a VS.

book

Article ID: 242893

calendar_today

Updated On:

Products

Service Virtualization

Issue/Introduction

After deploying a Kafka VS, none of the Virtual Services are shown in the Portal.
The vse.log showed errors similar to:

2022-06-01 07:21:58,377Z (17:21) [ServerRequestResponder 6] WARN  com.itko.lisa.net.RemoteMethodExec - InvocationTargetException on invoke getResourceName
java.lang.reflect.InvocationTargetException
 at sun.reflect.GeneratedMethodAccessor62.invoke(Unknown Source)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
 at java.lang.reflect.Method.invoke(Method.java:498)
 at com.itko.lisa.net.RemoteMethodExec.execute(RemoteMethodExec.java:57)
 at com.itko.lisa.net.ClientBase.invokeColocated(ClientBase.java:282)
 at com.itko.lisa.net.ClientBase.invokeMethod(ClientBase.java:266)
 at com.itko.lisa.net.ClientBase.invokeMethod(ClientBase.java:242)
 at com.itko.lisa.net.VirtualServiceCoordClient.getResourceName(VirtualServiceCoordClient.java:195)
 at com.itko.lisa.vse.VirtualServiceStatus.<init>(VirtualServiceStatus.java:188)
 at com.itko.lisa.coordinator.VirtualServiceImpl.getServiceInfo(VirtualServiceImpl.java:449)
 at sun.reflect.GeneratedMethodAccessor55.invoke(Unknown Source)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
 at java.lang.reflect.Method.invoke(Method.java:498)
 at com.itko.lisa.net.RemoteMethodExec.execute(RemoteMethodExec.java:57)
 at com.itko.lisa.net.ServerRequestHandler.processRMIMessage(ServerRequestHandler.java:533)
 at com.itko.lisa.net.ServerRequestHandler.access$600(ServerRequestHandler.java:70)
 at com.itko.lisa.net.ServerRequestHandler$5.run(ServerRequestHandler.java:451)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
 at java.util.concurrent.FutureTask.run(FutureTask.java:266)
 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
 at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.NullPointerException
...

Environment

Release : 10.6

Component : DevTest Virtual Service

Resolution

Open a support case to request patch patch_DE453115_10.6.0_GA.jar