API Portal: Portal Sync API Task fails with policy execution error
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API Portal: Portal Sync API Task fails with policy execution error

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Article ID: 242889

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Updated On:

Products

CA API Developer Portal

Issue/Introduction

Portal Sync API Scheduled Tasks are failing with WARNING message 

"Error processing management request: An authentication user is required but not present".

Environment

Release : 5.1

Component : API PORTAL

Cause

Multiple portman users in internal identity store which was left over from previous gateway enrollments.

Resolution

Step 1: Go to Tasks - Certificate Keys and Secrets - Manage Private Keys and note down the name of the portalman private key.

Now, from Identity Providers go to Internal Identity Provider and right-click select Search Identity Provider. Run a search on Internal Identity Provider and delete all the duplicate portalman identities other than the one which had the same name from the private key.

Check if the next Scheduled Task is successful, if it fails again go for the Step2.

Step 2: Cleanup of the portal enrollment on the gateway along with removing all the portman users from internal identity store.

Remove the enrollment of tenant gateway as per the steps in this document.

https://techdocs.broadcom.com/us/en/ca-enterprise-software/layer7-api-management/api-developer-portal/5-1/install-configure-and-upgrade/post-installation-tasks/enroll-a-layer7-api-gateway.html

See: Failed Gateway Deployment? section.

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Enroll Gateway with portal and restart gateway service.