Enabling Spring FilterChain additional logging for "No Prompt visible for User Input"

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Article ID: 242719

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio)

Issue/Introduction

We have observed an issue where User Input Action is not returning the prompt to user to choose the option.

It was showing waiting for the previous process to finish but when i checked the running processes in jmx console there was no process running. After restarting it fixed the issue. 

Cause

In review of the logs and we could find nothing that might bring the light on the issue. We identified some of the web-socket requests are successfully executed but some failed. The following requests are always get the 200 response code:
GET /websocket/info
GET /websocket/{param1}/{param2}/eventsource
The following get the 403 response code:
GET /websocket/{param1}/{param2}/websocket
POST /websocket/{param1}/{param2}/xhr_streaming
POST /websocket/{param1}/{param2}/xhr_send

Environment

Release : 6.7 and higher

Component : CA RELEASE AUTOMATION CORE

Resolution

With default logging it was not clear why the 403 response code is received. To troubleshoot, it requires to enablement of additional logging for Spring FilterChain as mentioned below. Post change on recurrence, the chain of filters being called for each request will be captured.

  • Add the following line to the NAC file $INSTALL_DIR\webapps\datamanagement\WEB-INF\log4j.properties:
log4j.logger.org.springframework.security.web.FilterChainProxy=DEBUG

(screen shot of file after change, last line is newly inserted one)

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=Gg1YlXbVqQdJ+oNE0OTyJg==

  • Restart the NAC service 

Note: Collect NAC logs, along with time-frame of issue and open a ticket with Technical Support for assistance.