Some account users can't see devices they should see.
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Some account users can't see devices they should see.

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Article ID: 242548

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Some of our account users can not see some of the devices they should be able to. The devices have the origin which the account has been assigned, and this has been confirmed from the database CM_COMPUTER_SYSTEM table. 

Environment

Release : 20.3

Component : UIM - UMP_ADMINCONSOLE2

Cause

The hub for these robots is missing the origin. When the hub probe activates it reads robot.sds one time and caches the info, and it is there the origin for these robots is missing. 

Resolution

 

hub_9.35tf1. 

1 Identify all of the robots with a missing origin.
This KB doc can be used:
UIM How to find robots with no origin in robot.sds
Article Id: 249095
https://knowledge.broadcom.com/external/article?articleId=249095

2 Remove all of the robots with a missing origin. 
IM console > Tools > Find > enter the robot name > identify the hub that has the robot 
Go to that hub > hub probe configure > Robots tab > identify the robot > right click > Remove 

3 After all of the robots missing the origin have been removed deploy hub_9.35tf1 to the hubs. 

Additional Information

To verify the origin is there go to Admin Console > the hub with the problem robots > hub probe > 3 dots menu > View Probe Utility in New Window > select get_robots > click the green arrow. 

Or for Windows hub: open a command window > change directory to $\Nimsoft\hub > run sdsfile -v robot.sds > robot.txt.

This data is kept at the hub in $\Nimsoft\hub\robot.sds. By design origin should never be blank, if a robot does not provide an origin to the hub the hub auto assigns the origin.