ErrorMessage: GeneralException Occurred. Failed to get Deployment Solution agent, Return code 0. The object is not loaded

book

Article ID: 242501

calendar_today

Updated On:

Products

Client Management Suite

Issue/Introduction

During image deployment, and at the process where the machine is joined to the domain, the process fails and the following error is seen on the task:

GeneralException occured 'Failed to get Deployment Solution agent', return code 0, system error 'The object is not loaded (0x80043100)'

This is an intermittent issue.  Running the imaging job again always seems to resolve the issue.

The PECTAgent logs show the following:

Description: 
  Failed to create object 'Altiris.DeploymentSolutionAgent', agent is stopping. This is normal, agent will not create any requested objects while stopping

Description: 
  _com_error exception: 0x80043100 Agent 'Altiris.DeploymentSolutionAgent' is not loaded

Description: 
  DS Task: 'Unknown' task failed, failed to initialize the task handler. GeneralException occured 'Failed to get Deployment Solution agent', return code 0, system error 'The object is not loaded (0x80043100)', location 'DeploymentSolutionAgent_Task.cpp:112'

Description: 
  [10:IN: 61C -> 0, RECV: 34E28419] Failed to resolve target address '<NS server>.com:443' from list '<NS server>.com:443', the address will be ignored, error: No such host is known (11001)

The DSTask logs show the following:

[2022/05/16 09:48:28.957 1656:1600 <TRC>] ..\common\system\[email protected] Error [email protected]
[2022/05/16 09:48:28.973 1656:1600 <TRC>] ..\common\system\[email protected] Error [email protected]
[2022/05/16 09:48:28.973 1656:1600 <TRC>] ..\common\system\[email protected] Error [email protected]
[2022/05/16 09:48:28.973 1656:1600 <TRC>] ..\common\system\[email protected] Error getting @joinPassword
[2022/05/16 09:48:28.973 1656:1600 <TRC>] ..\common\system\[email protected] Error getting @joinPassword

 

Environment

ITMS 8.6 RU2

DS 8.6 RU2

Resolution

In this case the VPN pipe was being saturated at the time the machine was trying to join the domain and this appears to have been causing Active Directory issues.

Additional Information

179201 DS 8.x Automation Logs