STUCK_THREADS related error in WebLogic console logs for Risk Authentication
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STUCK_THREADS related error in WebLogic console logs for Risk Authentication

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Article ID: 242407

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Updated On:

Products

CA Risk Authentication CA Advanced Authentication

Issue/Introduction

After running AA transactions for a while, timeout errors are encountered when invoking Advanced Authentication APIs. The issue is remediated via restart of WebLogic application server. After running for a while the issue resurfaces again.

In the WebLogic Console logs one can see the error below.

                   Symtom{STUCK_THREADS,HIGH,ThreadPoolRuntime,ThreadPool has stuck threads}

Error log from stdout.log 

"[STUCK] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'" #29 daemon prio=1 os_prio=0 tid=0x00007f0945865000 nid=0x3f0e in Object.wait() [0x00007f0971eaf000]

Environment

Release : All supported releases of Advanced Authentication

Component : Risk Authentication

Cause

CA Strong Authentication server's DB connections can get  exhausted if not properly configured.

Resolution

Please restart  the AA services and Applications after instating the two changes below:

1. As shown below, please configure CA Strong Authentication server's  database connections by updating the arcotcommon.ini file in <ARCOT_HOME>/conf directory 

MinConnections=16
MaxConnections=64
IncConnections=2
MaxIdleConnections=16

2. Run this SQL Database query such that any lock held on internal device table or user table is released in a timely fashion for optimal CA risk Authentication transaction processing.

update ARRFCONFIGURATION set value=5 where category='GLOBAL' and name='DEVICELOCKEDTIMEDIFF';
update ARRFCONFIGURATION set value=5 where category='GLOBAL' and name='USERLOCKEDTIMEDIFF';

3. Please also ensure tables that grow quickly such as ARRFSYSAUDITLOG table (that are recommended to be trimmed) are not allowed to grow too large.

Additional Information

None.