igateway process terminates
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igateway process terminates

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Article ID: 242376

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Updated On:

Products

CA Workload Automation AE

Issue/Introduction

Igateway process is getting terminated

root     18489     1  0 17:45 ?        00:00:02 ./igateway -b

root    18497     1  0 17:45 pts/1    00:00:00 /bin/sh ./WDigateway.sh

In this case the “igateway –b” process starts and gets terminated by itself.

Following error is shown in $IGW_LOC (/opt/CA/SharedComponents/iTechnology) igateway.log file

[1450498928]  FATAL :: main: Server failed to start

[1450498928]  ERROR :: SyncTCPConnAcceptor::start : unable to start acceptor on port [ 0 , errno: 99 ]

[1450498928] ERROR :: SyncTCPListener::startConnectors : connector for port [ 0 ] failed to start and mustlisten set to true

[1450498928]  ERROR :: SyncTCPListener::start : unable to start connector/s

[1450498928]  ERROR :: TCPTransportReceiver::start : transport receiver [ TCP ] failed to start

[1450498928] ERROR :: TransportReceiverHandler::start : transport receiver [ TCP] failed to start

[1450498928] FATAL :: Server::startReceivers : Unable to start receiver [ TCP ]

[1450498928] FATAL :: Server::startReceivers : unable to start server

[1450498928] ERROR :: Server::start : Receivers didnot get started as expected

[1450498928] FATAL :: main: Server failed to start

Environment

Release : 11.3.6

Component :

Cause

In certain cases after successful installation of EEM application, the iGateway does start and stop immediately.

In the igateway.log file the above error messages are logged:

Quote"
[1450498928]  FATAL :: main: Server failed to start

[1450498928]  ERROR :: SyncTCPConnAcceptor::start : unable to start acceptor on port [ 0 , errno: 99 ]
"UnQuote

The "errno: 99" means that the iTechnology iGateway application is not able to create a socket connection.

The causes for socket creation failure can be various, depending upon the OS, the firewall configuration, the ports not being enabled, the IPC has certain problems which are beyond CA’s scope of effort, and any other environment related problems, etc...

Resolution

1.   Stop the EEM related services

a.   iTechnology iGateway

2.   Go to the $IGW_LOC location. This is the location where iTechnology iGateway is installed.

3.   Open the igateway.conf file for editing

a.   Change the bind-address value from localhost to IP Address/hostname in “TCPListener” connector.

        <TransportReceiver imageName="TCPListener" name="TCP">

                <implementation>synchronous</implementation>
                <Connector name="secure_safetynet">
                        <bind-address>IP Address/Hostname</bind-address>
                        <port>0</port>
                        <mustlisten>true</mustlisten>
                        <conntype>secure</conntype>
                        <conntimeout>86400</conntimeout>
                        <maxconnections>100</maxconnections>
                        <maxrequestbytes>10000000</maxrequestbytes>
                        <maxpiperequests>100</maxpiperequests>
                </Connector>

b.   If after changing this the same problem still occurs, then change the bind-address in the “safetynet” connector from localhost to IP Address/ Hostname

                <Connector name="safetynet">
                        <bind-address>IP Address/Hostname</bind-address>
                        <port>0</port>
                        <mustlisten>true</mustlisten>
                        <conntype>insecure</conntype>
                        <conntimeout>86400</conntimeout>
                        <maxconnections>100</maxconnections>
                        <maxrequestbytes>10000000</maxrequestbytes>
                        <maxpiperequests>100</maxpiperequests>
                        <maxAcceptRate/>
                </Connector>

 

4.   Save the file and start the iTechnology iGateway