Using XOG: Process Action ID Required Field Can Be Left Blank
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Using XOG: Process Action ID Required Field Can Be Left Blank

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Article ID: 242302

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Creating an Action in a BPM Process without filling in the 'Required, Enter Once, Unique' Action ID field should not be allowed when using XOG to create the the Process. After the action is created, If the user wants to update the action, from the UI, although the Step Action ID is required, it can still be left blank when clicking 'Save' or 'Save and Return' button. 

Steps to Reproduce:

  1. Create a Process XOG Write file that includes a Step with an Action for a Custom Script
    • In the XOG file for the action, set the Action Code = "" so that it is in the file but is blank
  2. XOG Write the Process Definition 
    • ! This should not be successful 
  3. Go to Classic Administration, Processes and Open this process
  4. Go to the Step and open the Action
    • The user sees a blank Action ID
    • Clicking 'Save' or 'Save and Return' button will not revalidate the 'Action ID' field 

Expected Results: The XOG should validate the Action Code field is Required, Enter Once, Unique and not create the action if the rule is violated. 

Actual Results: The Action is successfully created with a blank Action ID (action code). 

 

Environment

Release : 16.0.1, 16.0.2 

Cause

DE65310 - Required validation is not present for Action Code in the XOG flow. 

Workaround: Update the XOG file to have an Action Code value and recreate the entire process.  

Resolution

Targeted Fix in Release 16.0.3 

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