Identity policy doesn't work correctly if attribute value is empty / NULL
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Identity policy doesn't work correctly if attribute value is empty / NULL

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Article ID: 242237

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Updated On:

Products

CA Identity Manager

Issue/Introduction

When a user attribute is empty (without any value) and the Identity Policy condition is set to "NOT equal" some value of this attribute.  The the Identity policy using this attribute is not able to recognize empty value, therefore IP is wrongly assigned or unassigned.

 

 

Environment

Release : 14.4

Component : IdentityMinder(Identity Manager)

Cause

Checking value =/= NULL will always provide false as result.

This is by design.

Resolution

Use double check:

Attribute =/= expected_value

or

Attribute =/= *