search cancel

Broadcom API Gateway - Impact of CVE-2022-22947

book

Article ID: 242031

calendar_today

Updated On:

Products

CA API Gateway

Issue/Introduction

CVE-2022-22947 vulnerability

Environment

Release : 10.1

Component : API GATEWAY

Cause

In spring cloud gateway versions prior to 3.1.1+ and 3.0.7+ , applications are vulnerable to a code injection attack when the Gateway Actuator endpoint is enabled, exposed and unsecured. A remote attacker could make a maliciously crafted request that could allow arbitrary remote execution on the remote host.

Resolution

API Gateway is not impacted by CVE-2022-22947 as we do not use Spring Cloud Gateway library in it. 

Additional Information

CVE-2022-22947 - Reference link here