search cancel

Windows agent won't start with U02000313 / U02000328

book

Article ID: 242019

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

Attempting to install a windows agent on a server that is remove to the Automation Engine / AE components; the agent is failing with an error; see below:

Log snippet:


20220518/103743.362 - U02000379 Initiating connection to server 'AE.FQDN.ADDRESS:8444' using WebSocket URI: 'wss://AEIP:8444/agent'.
20220518/103804.363 - U02000313 Communication error with partner 'https://AE.FQDN.ADDRESS:8444/agent', error: 'A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond'.
20220518/103804.363 - U02000343 Server connection has been closed.
20220518/103804.864 - U02000379 Initiating connection to server 'AE_SERVERNAME:8444' using WebSocket URI: 'wss://AEIP:8444/agent'.
20220518/103825.865 - U02000313 Communication error with partner 'https://AE_SERVERNAME:8444/agent', error: 'A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond'.
20220518/103825.865 - U02000343 Server connection has been closed.
20220518/103826.366 - U02000379 Initiating connection to server 'AE.FQDN.ADDRESS:8444' using WebSocket URI: 'wss://AEIP:8444/agent'.
20220518/103847.367 - U02000313 Communication error with partner 'https://AE.FQDN.ADDRESS:8444/agent', error: 'A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond'.
20220518/103847.367 - U02000343 Server connection has been closed.
20220518/103847.869 - U02000302 Agent shutdown has been initiated with return code '68'.
20220518/103847.869 -           Waiting for File Transfer threads ...
20220518/103847.869 - U02000041 Shutdown Agent 'WIN02'.
20220518/103847.869 - U02000328 Unexpected error on listen port occurred, reason 'The I/O operation has been aborted because of either a thread exit or an application request', position 'agent-windows/shared-c/tcpip/Listener.cpp#tcp::Listener::doAcceptWSConnection:52'.
20220518/103847.869 - U02000135 Thread 'TCP-Thread' ended.
20220518/103847.870 - U02000002 Agent 'WIN02' version '21.0.2+build.31' ended abnormally.

Environment

Release : 12.3

Component :

Resolution

Be sure that all firewall communication is open between the windows agent and AE server.  In this case specifically, look at inbound ports on the AE server

Possible troubleshooting to help find if there are network problems:
Run the following in windows powershell from agent server TO the AE server where the JCP is that's used in the agent ini connection= setting:

Test-NetConnection -ComputerName "IP_OR_SERVERNAME_OR_FQDN" -Port "JCP_port_number" -InformationLevel "Detailed"

Additional Information

For firewall information, please see https://docs.automic.com/documentation/webhelp/english/ALL/components/DOCU/21.0/Automic%20Automation%20Guides/Content/_Common/Security/Security_Hardening_AEFirewallPorts.htm#link2