VNA installation fails on systems having different locale than en_US. 
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VNA installation fails on systems having different locale than en_US. 

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Article ID: 241941

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Updated On:

Products

DX NetOps CA Virtual Network Assurance

Issue/Introduction

Installation of Virtual Network Assurance on a system having locale set different than "en_US.UTF8"  (for example "LANG=fr_FR.utf8") fails with error:

Java version 11 is not installed. Please install Java 11 

This happens even if Java version 11 is already installed on the server, and having followed all the steps from the VNA documentation, including selecting the JDK version of Java using the alternatives tools:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/virtual-network-assurance/21-2/installing.html

 

Environment

Release : 21.2

Component : Virtual Network Assurance For CA Performance Management

Cause

In the VNA installation script there is a check for JDK version with hard coded string which is causing the failure.

For example, installing on a French OS Linux system with locale set to "LANG=fr_FR.utf8" cause the alternatives command to return "priorité" as seen below:

 LANG=fr_FR.UTF=8  alternatives --display java | grep prior
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.312.b07-2.el8_5.x86_64/jre/bin/java - famille java-1.8.0-openjdk.x86_64 priorité 1800312
/usr/lib/jvm/java-11-openjdk-11.0.13.0.8-4.el8_5.x86_64/bin/java - famille java-11-openjdk.x86_64 priorité 1

While the install check expect the word "priority".  And this is causing the failure.

Resolution

As a workaround, set the locale to en_US.UTF8 to solve the issue:

export LANG=en_US.UTF8 ; export LC_ALL=$LANG

Additional Information

We have submitted Defect DE536001 and working to fix this issue.

We plan to have it included in next VNA release.

 

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