The asset can not be contacted. Verify that the asset is functional and connected to the network. Error : The network path was not found. in CCS
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The asset can not be contacted. Verify that the asset is functional and connected to the network. Error : The network path was not found. in CCS

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Article ID: 241803

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Updated On:

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Control Compliance Suite Standards Server Control Compliance Suite Control Compliance Suite Standards Module

Issue/Introduction

Control Compliance Suite (CCS)

When running a data collection/CER job using agentless data collection, you see the following error message in the job details.

The asset can not be contacted. Verify that the asset is functional and connected to the network. Error : The network path was not found.

OR

Enumerating all of the users on <AssetNetBiosName> - BVNTProcessQuery::ObjectTypeAccount(): Processing machine scope=0AThe computer can not be contacted. Verify that the computer is running, connected to the network and not configured to block file and printer sharing. - The RPC server is unavailable.

With Verbose logging enabled you may see something similar to what is below in the %ProgramData%\Symantec.CSM\Logs\CCSManager\DCInfra\WindowsDC.log file.

16 | 01 | 05/16/22 | 10:33:32 | LogonTokenHolder.cpp | 216 | Blade.WorkerProcess.exe | 2920 | 7576 | UserImpersonationTokenHolder::Logon - LogonUser Successful.Now validating credentials For User : <domain\user>
13 | 02 | 05/16/22 | 10:33:32 | BVNTComputerCacheSingleton.cpp | 85 | Blade.WorkerProcess.exe | 2920 | 7576 | GetComputerNameFromIP(): Input string is not a IPAddress. skip this! 
16 | 01 | 05/16/22 | 10:33:32 | LogonTokenHolder.cpp | 356 | Blade.WorkerProcess.exe | 2920 | 7576 | UserImpersonationTokenHolder::ValidateCredentials - Validate credential failed with error [ 53 ] For Target [ NETBIOSNAME ].
16 | 02 | 05/16/22 | 10:33:32 | registry.cpp | 417 | Blade.WorkerProcess.exe | 2920 | 7576 | Exception in BVNTRegistry::GetValue() with code:00000002

OR

You see the following error in the CCS Console.

 : The asset can not be contacted. Error : The network path was not found. =0AThe computer can not be contacted. Verify that the computer is running, connected to the network and not configured to block file and printer sharing. - The network path was not found.

And you see the following in the WindowsDC.log file.

38 | 00 | 04/23/24 | 13:10:29 | ntcomputer.cpp | 666 | Blade.WorkerProcess.exe | 320 | 5204 | BVNTComputer::GetInfoNonRestricted(): NetServerGetInfo() returned 53
38 | 00 | 04/23/24 | 13:10:29 | ntcomputer.cpp | 666 | Blade.WorkerProcess.exe | 320 | 8336 | BVNTComputer::GetInfoNonRestricted(): NetServerGetInfo() returned 53
38 | 00 | 04/23/24 | 13:10:29 | ntcomputer.cpp | 678 | Blade.WorkerProcess.exe | 320 | 5204 | BVNTComputer::GetInfoNonRestricted(): Setting up NBLogon \\SERVER1
38 | 00 | 04/23/24 | 13:10:29 | ntcomputer.cpp | 678 | Blade.WorkerProcess.exe | 320 | 8336 | BVNTComputer::GetInfoNonRestricted(): Setting up NBLogon \\SERVER1
38 | 00 | 04/23/24 | 13:10:29 | ntcomputer.cpp | 666 | Blade.WorkerProcess.exe | 320 | 1844 | BVNTComputer::GetInfoNonRestricted(): NetServerGetInfo() returned 53
38 | 00 | 04/23/24 | 13:10:29 | ntcomputer.cpp | 666 | Blade.WorkerProcess.exe | 320 | 2212 | BVNTComputer::GetInfoNonRestricted(): NetServerGetInfo() returned 53
38 | 00 | 04/23/24 | 13:10:29 | ntcomputer.cpp | 678 | Blade.WorkerProcess.exe | 320 | 1844 | BVNTComputer::GetInfoNonRestricted(): Setting up NBLogon \\SERVER1
38 | 00 | 04/23/24 | 13:10:29 | ntcomputer.cpp | 678 | Blade.WorkerProcess.exe | 320 | 2212 | BVNTComputer::GetInfoNonRestricted(): Setting up NBLogon \\SERVER1
16 | 02 | 04/23/24 | 13:10:29 | registry.cpp | 417 | Blade.WorkerProcess.exe | 320 | 5204 | Exception in BVNTRegistry::GetValue() with code:00000002
16 | 02 | 04/23/24 | 13:10:29 | registry.cpp | 417 | Blade.WorkerProcess.exe | 320 | 2212 | Exception in BVNTRegistry::GetValue() with code:00000002
30 | 01 | 04/23/24 | 13:10:29 | ErrorLog.cpp | 936 | Blade.WorkerProcess.exe | 320 | 5204 | Entering ReadListProcessInterfaceImpl::AddExceptionFile()
30 | 01 | 04/23/24 | 13:10:29 | ErrorLog.cpp | 936 | Blade.WorkerProcess.exe | 320 | 2212 | Entering ReadListProcessInterfaceImpl::AddExceptionFile()
30 | 02 | 04/23/24 | 13:10:29 | ProcessInterface.cpp | 174 | Blade.WorkerProcess.exe | 320 | 5204 | ReadListProcessInterfaceImpl::AddExceptionFile() - 1 - <message level="0" target="SERVER1"><desc><![CDATA[: The asset can not be contacted. Error : The network path was not found. 
The computer can not be contacted. Verify that the computer is running, connected to the network and not configured to block file and printer sharing. - The network path was not found.]]></desc><asset type="WNT.MACHINE"><DOMAINWORKGROUPNAME> <![CDATA[DOMAIN]]></DOMAINWORKGROUPNAME> <RELATIVENAME> <![CDATA[SERVER1]]></RELATIVENAME> </asset><internalerror><![CDATA[0]]></internalerror></message>
30 | 02 | 04/23/24 | 13:10:29 | ProcessInterface.cpp | 174 | Blade.WorkerProcess.exe | 320 | 2212 | ReadListProcessInterfaceImpl::AddExceptionFile() - 1 - <message level="0" target="SERVER1"><desc><![CDATA[: The asset can not be contacted. Error : The network path was not found. 
The computer can not be contacted. Verify that the computer is running, connected to the network and not configured to block file and printer sharing. - The network path was not found.]]></desc><asset type="WNT.MACHINE"><DOMAINWORKGROUPNAME> <![CDATA[DOMAIN]]></DOMAINWORKGROUPNAME> <RELATIVENAME> <![CDATA[SERVER1]]></RELATIVENAME> </asset><internalerror><![CDATA[0]]></internalerror></message>

Cause

There are a number of things that can cause this error when running agentless data collection:

  • Port 445 being blocked (or any other ports required for agentless data collection).
  • File and Printer sharing not being enabled or is being blocked by the local firewall.
  • The "Server" service is not running.
  • Having a type or incorrectly configured FQDN in the Domain Cache credential can also cause this issue.

Resolution

Steps to resolve this issue:

First double check the FQDN setting in the Domain Cache credential. If this has a typo or is incorrect, that will cause this issue. Once that is corrected, the data collection jobs will run successfully.

Make sure that all the required Ports are open for agentless data collection.

NOTE: If a local firewall is on the remote Windows server or possibly even a firewall(s) in between the CCS Manager and Windows server, then refer to the section "If the CCS infrastructure components must traverse a firewall to contact the Domain Controller, you must open additional ports for Windows authentication." in the lower section in the required network ports documentation below for additional ports that need to be enabled.

Required Network Ports for CCS

 

Make sure that the user account has all the required permissions (agentless data collection).

Minimum Privileges for data collection on various platforms

For setting up WMI permissions see the following 2 Microsoft articles.

Authorize WMI users and set permissions
Group Policy Planning and Deployment Guide

 

Verify that all the required services for connecting to the remote registry are up and running or properly configured. Especially the "Server" service.

Error: 'Connecting to remote registry failed with: The network path was not found. (error 53)

 

Installing a CCS agent on the server

If a server has been hardened or the required ports for agentless collection are not allowed, you could install an agent on that server and that should resolve the permissions issue as the agent runs as SYSTEM (Windows) or root (Linux) so it has all the required permissions, and the agent requires less ports to be open to function properly.

NOTE: If you have credentials set in the CCS console for Agentless OS data collections, and also use agents for Agent-Based data collection, see the following KB to avoid errors with credentials being sent to an agent-based OS data collection job:
CCS Agent-based data collection job is trying to use saved credentials that are set up for agentless scanning.

 

Additional Information

A couple of MS Articles talking about the Error 53.

https://learn.microsoft.com/en-us/answers/questions/832405/cant-mount-file-share-(tcp-port-445)

https://learn.microsoft.com/en-us/troubleshoot/azure/azure-storage/files/connectivity/files-troubleshoot-smb-connectivity?tabs=windows