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The asset can not be contacted. Verify that the asset is functional and connected to the network. Error : The network path was not found.

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Article ID: 241803

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Updated On:

Products

Control Compliance Suite Standards Server

Issue/Introduction

Control Compliance Suite, when running a data collection/CER job we are seeing the following error message in the job details.

The asset can not be contacted. Verify that the asset is functional and connected to the network. Error : The network path was not found.

OR

Enumerating all of the users on <AssetNetBiosName> - BVNTProcessQuery::ObjectTypeAccount(): Processing machine scope=0AThe computer can not be contacted. Verify that the computer is running, connected to the network and not configured to block file and printer sharing. - The RPC server is unavailable.

With Verbose logging enabled you may see something similar to what is below in the %ProgramData%\Symantec.CSM\Logs\CCSManager\DCInfra\WindowsDC.log file.

16 | 01 | 05/16/22 | 10:33:32 | LogonTokenHolder.cpp | 216 | Blade.WorkerProcess.exe | 2920 | 7576 | UserImpersonationTokenHolder::Logon - LogonUser Successful.Now validating credentials For User : <domain\user>
13 | 02 | 05/16/22 | 10:33:32 | BVNTComputerCacheSingleton.cpp | 85 | Blade.WorkerProcess.exe | 2920 | 7576 | GetComputerNameFromIP(): Input string is not a IPAddress. skip this! 
16 | 01 | 05/16/22 | 10:33:32 | LogonTokenHolder.cpp | 356 | Blade.WorkerProcess.exe | 2920 | 7576 | UserImpersonationTokenHolder::ValidateCredentials - Validate credential failed with error [ 53 ] For Target [ NETBIOSNAME ].
16 | 02 | 05/16/22 | 10:33:32 | registry.cpp | 417 | Blade.WorkerProcess.exe | 2920 | 7576 | Exception in BVNTRegistry::GetValue() with code:00000002

Cause

There are a number of things that can cause this error.
Port 445 being blocked, file and printer sharing not being enabled. or even if the "Server" service is not running.

Resolution

Make sure that all the required Ports are open.
https://techdocs.broadcom.com/us/en/symantec-security-software/information-security/control-compliance-suite/12-5-2/ccs-support-matrix-v123000389-d8e133191/network-ports-v122827897-d8e138139.html

If a firewall is on the remote Windows server or even in between the CCS Manager and Windows server then refer to the section below.

"If the CCS infrastructure components must traverse a firewall to contact the Domain Controller, you must open additional ports for Windows authentication."

Make sure that the account has all the required permissions.

https://techdocs.broadcom.com/us/en/symantec-security-software/information-security/control-compliance-suite/12-5-2/configuring-roles-and-permissions-v122981946-d8e37312/minimum-required-privileges-for-data-collection-on-v124923418-d8e151107.html#v124923418

For setting up WMI permissions see the following 2 Microsoft articles.

https://technet.microsoft.com/en-us/library/cc771551%28v=ws.11%29.aspx
https://technet.microsoft.com/en-us/library/cc754948%28v=ws.10%29.aspx

Also make sure that all the required services for connecting to the remote registry are up and running or properly configured. Especially the "Server" service.

https://social.technet.microsoft.com/Forums/ie/en-US/af20ec5c-c950-4f74-b4c5-1f8e62c4dd7b/error-connecting-to-remote-registry-failed-with-the-network-path-was-not-found-error-53?forum=winserverNAP