EEM upgrade failed with error "Failed to take backup of existing application" - ERROR iGateway – iGateway service shutdown returned 2
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EEM upgrade failed with error "Failed to take backup of existing application" - ERROR iGateway – iGateway service shutdown returned 2

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Article ID: 241738

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

Ran the setup.exe from R12 DVD\modules\EEM and it fails with error:
"Failed to take backup of existing application"

Noticed the below error message in the file “eiam-install” under Windows Temp directory:

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ERROR iGateway – iGateway service  shutdown returned 2

FATAL iGateway – Failed to stop iGateway server.  iGateway stop returned 2

FATAL BackupAction – Exception occurred during backup

java.lang.Exception: Failed to stop iGateway server

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Environment

Release : R12.0

Component : WA AE/AUTOSYS RELATED EEM

Cause

Installer wants to stop the service itself though the service was in stopped state.

Resolution

Start the EEM Services and then run the setup.exe