WA Agent for Informatica: After migrating Informatica SQL Server repository from SQL Azure Elastic Pool to SQL Azure Managed instance, we are getting TLS error
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WA Agent for Informatica: After migrating Informatica SQL Server repository from SQL Azure Elastic Pool to SQL Azure Managed instance, we are getting TLS error

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Article ID: 241693

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Updated On:

Products

CA Workload Automation DE - Business Agents (dSeries)

Issue/Introduction

We use CA WA Agent on Linux with Informatica plugin.

When the Informatica SQL Server repository was on SQL Azure elastic pool, the connectivity of the CA agent Infa plug-in worked.

When we intentionally migrated the repository database from elastic pool to SQL Azure managed instance, I changed the server name reference in file /opt/CA/WA_Agent/config/informatica/<server>/<dbname>.properties file.

The SQL database name, SQL login name and SQL login password didn't change.

Now I'm getting the error 

InformaticaPlugin.pool-1-thread-1.CybInformaticaLoggerHandlerWOB.log[:80] - Reason:
Login failed due to client TLS version being less than minimal TLS version allowed by the server.

I have verified that both the Linux server client and the Azure SQL managed instance are at TLS V1.2.

Does the encrypted password need to be regenerated if the server name changes but the login/pwd doesn't?

 

Environment

Release : 12.0

Component : Workload Automation Agent for Informatica

Cause

MS SQL JDBC driver does not support TLS 1.2

Resolution

Replace MS SQL JDBC driver for Informatica plugin in <agent installation directory>/jars/ext directory with latest JDBC driver with JRE 8 support as agent is shipped with Java 8.

For example, mssql-jdbc-8.x.0.jre8.jar

When you are replacing the JDBC driver, remove the old JDBC driver(s) in the <agent installation directory>/jars/ext directory.

Additional Information

https://knowledge.broadcom.com/external/article?articleId=203693