Messages released from Content Quarantine not delivered to expected Scanner
search cancel

Messages released from Content Quarantine not delivered to expected Scanner

book

Article ID: 241630

calendar_today

Updated On:

Products

Messaging Gateway

Issue/Introduction

When releasing messages from the Messaging Gateway (SMG) Content Quarantine either from the Control Center GUI or from DLP via FlexResponse, the released messages are not processed by the expected SMG Scanner.

Cause

Messages released from the Content Quarantine are released to the first Scanner record in the internal database list of scanners.

Resolution

This is expected behavior.

The SMG Control Center releases messages held in the Content Quarantine by listing all SMG scanners in the Control Center and then delivering the message to port 41015 on the first Scanner in the list. If it cannot deliver to the first scanner then it will attempt the next scanner in the list and then the next until it can deliver the message or it completes the list. For further deliveries, the Control Center will move to the next scanner in the list in round-robin fashion and repeat the process.

This behavior is not currently configurable but the order of the Scanners in the Control Center can be changed by sequentially deleting Scanners from the Administration > Configuration list and then adding the scanner back via the Add Scanner wizard. This will change the internal ID of the scanner. Once the desired destination Scanner is the first SMG Scanner in the list it will begin getting the messages released from the SMG Content Quarantine. This can be confirmed by releasing messages after a scanner has been removed and re-added.