EXCEPTION_ACCESS_VIOLATION when running coracleanup in 17.3 RU 14:
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EXCEPTION_ACCESS_VIOLATION when running coracleanup in 17.3 RU 14:

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Article ID: 241600

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

The following error appears when running coracleanup:

# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007ffa88dd2e32, pid=7288, tid=10280
#
# JRE version: OpenJDK Runtime Environment (11.0.3+7) (build 11.0.3+7)
# Java VM: OpenJDK 64-Bit Server VM (11.0.3+7, mixed mode, tiered, compressed oops, g1 gc, windows-amd64)
# Problematic frame:
# C  [ucrtbase.dll+0x22e32]
#
# Core dump will be written. Default location: D:\CA\Service Desk Manager\bin\hs_err_pid7288.mdmp
#
# If you would like to submit a bug report, please visit:
#   https://github.com/AdoptOpenJDK/openjdk-build/issues
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

 

STEPS to reproduce:

 

1) Create a CI (Log into SDM > Administration > CA CMDB > CI List > Create New)

2) Fill in only the "Name" and "Class". then click continue.

3) Fill in the "Mac Address" field with anything but don't include any alphanumeric characters 0-9a-zA-Z.

4) Run coracleanup

Environment

Release : 17.3

Component : SDM - Configuration Management (CMDB/Visualizer/Grloader)

Cause

Defect with 17.3 RU 14 and previous versions

Resolution

Upgrade to 17.3 RU 15 or later to solve this issue.