Uninstall of Identity Manager components showing an error "A suitable JVM could not be found"
search cancel

Uninstall of Identity Manager components showing an error "A suitable JVM could not be found"

book

Article ID: 241572

calendar_today

Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

When trying to uninstall IM components, it fails with "a suitable JVM could not be found"

Need to uninstall in order to reinstall on a different server.

Environment

Release : 14.x

Component : IdentityMinder(Identity Manager)

Cause

Inconsistency with the uninstaller

Resolution

1. Navigate to the uninstall folder of the specific application (for example, for Connector Server SDK it should be similar to
..\CA\Identity Manager\Connector Server SDK\_uninst
2. From command prompt, run Uninstaller.exe -is:log log.txt

3. Review log.txt and locate the JVM reference

Verifying JVM at C:\Program Files (x86)\CA\Identity Manager\Connector Server SDK\_uninst\_jvm\bin\java.exe
   for JVM: Java 1.7.0_80 by Oracle Corporation
C:\Program Files (x86)\CA\Identity Manager\Connector Server SDK\_uninst\_jvm\bin\java.exe does not exist
In VERIFY, the jvm is invalid.
Finding a JVM
Initiating JVM search based on hints...
Searching for Java 1.7.0_80 by Oracle Corporation using platform hints
WARNING: Invalid platform hint: The system cannot find the file specified.

4. Once we identified the required JVM (in this case 1.7.0_80) it should be installed and used with the installer in the following way:

Uninstaller.exe -is:log log.txt is:javahome <Path to java 1.7.0_80>

Note: please check java.exe does not exist in the same folder in a different name (ie java.exe.bk or other variation) - some security applications are known to rename old / out of data java.exe to eliminate vulnerabilities.