ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

"Missing tenant ID" or "Cannot Determine TenantInstance in Multitenant Mode" in Clarity logs

book

Article ID: 241567

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

After a change in the environment (for example, an upgrade), you are observing errors in the logs regarding "Missing tenant ID" or "Cannot Determine TenantInstance in Multitenant Mode".

Health Report may even show services as Invalid.

Cause

It is possible that services need to be re-created.

Environment

Release : 16.0.0

Component : Clarity Install and Upgrade

Resolution

As with any change in an environment, as a best practice, it is strongly recommended that you perform the necessary backups to be able to roll the changes back if needed.

In order to recreate all services:

  1. Ensure that the Clarity home folder is backed up, along with the properties.xml file. It will be convenient to take screenshots of the current configuration of the service configuration showing up in the CSA > [server] > CSA + Application + Background tabs.
  2. Stop all Clarity services:
    service stop all
  3. Note all Clarity services available:
    service status all
    In our example, we observe: beacon, nsa, app, app2, bg
  4. Remove all Clarity services:
    service remove all
  5. Re-add Clarity services*:
    service add deploy beacon nsa app bg [note that app2 is not listed in this step]
    service clone app [this will add app2]
  6. Start beacon and CSA:
    service start beacon nsa
  7. Log in to the CSA and review and adjust the services properties if needed (specially for app/app2/nsa services), if any values differ from the previous configuration. The screenshots from step 2 and backed up properties.xml should help achieving this.
  8. Start the rest of the services:
    service start app app2 bg

(*) In the event that instead of app2, app3 (or higher number) is created while cloning, and previous services are not listed (i.e.: app3 is created, app2 does not exist), or if you receive a message like "No service found with id: xxx", follow the steps from this KB article: I am receiving a "No service found with id: nsa" error when trying to add the nsa service