ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

OTK installer 4.4.1 can't be set in policy manager

book

Article ID: 241529

calendar_today

Updated On:

Products

CA API Gateway

Issue/Introduction

We are performing an OTK upgrade from 4.3.0 to 4.4.1 but we are having an issue when we try to set the skkar settings

 

The error:

UniqueKeyConflict for "OTK Scope Assertions"  - this failed to resolve with error  This Solution Kit does not allow overriding of this mapping.  This mapping requires the property "SK_allowMappingOverride: be set to trues by the .skar file autor

 

Cause

Customer had the original OTK 4.3.00.3789 version which had an older version of OTK Scope assertions.  This causes a conflict with the newer "OTK Scope Assertions" 

 

Environment

Release : 10.1

Component : API GATEWAY

Resolution

Customer had the original OTK 4.3.00.3789 version which had an older version of OTK Scope assertions. 

To resolve the conflict we needed to delete the “OTK Scope Assertion” from Task -> Server Modular Files  

 

Then perform the upgrade from Task -> Manage Solution kits