ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

JCP version 21.0 is not starting.

book

Article ID: 241216

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

The JCP cannot be started in version 21.0. The following exception is thrown:

20220505/172730.477 - 28     U00045014 Exception 'com.automic.agents.impl.TlsKeystoreReader$InvalidKeystoreException: "java.io.IOException: Integrity check failed: java.security.NoSuchAlgorithmException: Algorithm HmacPBESHA256 not available"' at 'com.automic.agents.impl.TlsKeystoreReader.tryToLoadKey():89'.
20220505/172730.478 - 28     U00045015 The previous error was caused by 'java.io.IOException: "Integrity check failed: java.security.NoSuchAlgorithmException: Algorithm HmacPBESHA256 not available"' at 'sun.security.pkcs12.PKCS12KeyStore.engineLoad()'.
20220505/172730.478 - 28     U00045015 The previous error was caused by 'java.security.NoSuchAlgorithmException: "Algorithm HmacPBESHA256 not available"' at 'javax.crypto.Mac.getInstance()'.

The JCP is started with the following Java version:

20220504/092203.507 - 21     U02000090 Java Runtime Environment version: '11.0.10'
20220504/092203.507 - 21     U02000421 Java Runtime Environment name: 'OpenJDK Runtime Environment'
20220504/092203.507 - 21     U02000091 Java Runtime Environment vendor: 'AdoptOpenJDK'

Cause

Defect in OpenJDK version 11.0.

Environment

Release : 21.0.2

Component : AUTOMATION ENGINE

Resolution

Please upgrade to a Java version > 11.0.13, i.e. 11.0.15

More information can be found here: