ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Supportability of MySQL 5.7 with RA

book

Article ID: 241118

calendar_today

Updated On:

Products

CA Release Automation - Release Operations Center (Nolio)

Issue/Introduction

Our RA production version is actually 6.6.0.10228.
We need to update urgently our database version actually MySQL 5.6 to a more recent and supported version of MySQL.

As described here https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/release-automation-nolio/6-6/installation/system-requirements.html the MySQL supported versions for RA 6.6 are:

MySQL 5.5, 5.6 and 8

5.5 and 5.6 are End of Support Life so I am trying to migrate to MySQL 8. Could you confirm that is supported for my RA configuration ?

Is the MySQL version 5.7 supported too?

Environment

Release : 6.6 OR higher

Component : RELEASE AUTOMATION CORE

Resolution

We reviewed the list of changes done in MySQL 5.7, and did not find in it anything that we'd suspect as impacting. 

So we expect Nolio to work fine with MySQL 5.7, and will provide our support if the customer faces issues connected to using this specific version of MySQL.

Additional Information

  • The new version of MySQL connector will be supported in future product version of CA Release Automation 6.8.