Workflow Approval task error java.lang.NullPointerException
search cancel

Workflow Approval task error java.lang.NullPointerException

book

Article ID: 241035

calendar_today

Updated On:

Products

CA Identity Manager CA Identity Suite CA Identity Governance

Issue/Introduction

After upgrading IDM from 14.2 to 14.4, the workflow approval is throwing java.lang.NullPointerException when trying to view the workflow item.

The first two approval stages work as expected but when the third stage approver goes to approve, the workflow no longer appears in the workflow items list. It's as if the workflow has disappeared.

Environment

IDM 14.4

Cause

The new workflow Approval Timeout field in 14.4 needs to be set.

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-manager/14-4/administrating/workflow/use-workflow-control-template-method/place-admin-tasks-under-workflow-control-template-method.html

Resolution

Set or increase the value in the Approval Timeout field of the workflow configuration. For example:

https://api-broadcom-ca-user.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=5k1I72eQRaOniE80WA4MnQ==