Unidentified UUID
search cancel

Unidentified UUID

book

Article ID: 240932

calendar_today

Updated On:

Products

CA Process Automation Base

Issue/Introduction

Hello In our PROD environment, while checking the logs file we got below error messages  even though all of our agents are active and reporting to console:

2022-05-03 06:47:55,132 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [_autoTPRecovery] Agent with id : 804c40c5-3b66-43fa-90b3-63278106155a is not reachable
com.optinuity.c2o.util.C2OException: Unidentified UUID while resolving node
...
2022-05-03 06:47:55,132 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [_autoTPRecovery] Agent with id : 411c7fb7-c140-416e-8901-922cd73c69d3 is not reachable
com.optinuity.c2o.util.C2OException: Unidentified UUID while resolving node
...
2022-05-03 06:47:55,132 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [_autoTPRecovery] Agent with id : a8257bed-6cfd-4182-b5f9-bd912426eacf is not reachable
com.optinuity.c2o.util.C2OException: Unidentified UUID while resolving node
...
2022-05-03 06:49:55,179 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [_autoTPRecovery] Agent with id : 804c40c5-3b66-43fa-90b3-63278106155a is not reachable
com.optinuity.c2o.util.C2OException: Unidentified UUID while resolving node
...
2022-05-03 06:49:55,179 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [_autoTPRecovery] Agent with id : 411c7fb7-c140-416e-8901-922cd73c69d3 is not reachable
com.optinuity.c2o.util.C2OException: Unidentified UUID while resolving node
...
2022-05-03 06:49:55,179 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [_autoTPRecovery] Agent with id : a8257bed-6cfd-4182-b5f9-bd912426eacf is not reachable
com.optinuity.c2o.util.C2OException: Unidentified UUID while resolving node

Environment

Release : 4.3.X

Component : Process Automation

Cause

Those UUIDs were from agents that were previously deleted, but the UUIDs remained in the database.

Resolution

L2 was able to clear up the problem with the 3 UUIDs on a WebEx using direct SQL update to the database.

Also removed the entries from domain.xml file from all the nodes in the cluster followed by restart of Orchestrator service in all the nodes.