ITPAM error Unidentified UUID while resolving node
search cancel

ITPAM error Unidentified UUID while resolving node

book

Article ID: 240932

calendar_today

Updated On:

Products

CA Process Automation Base Process Automation Manager

Issue/Introduction

Hello In our PROD environment, while checking the logs file we got below error messages  even though all of our agents are active and reporting to console:

2022-05-03 06:47:55,132 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [_autoTPRecovery] Agent with id : 804c40c5-3b66-43fa-90b3-63278106155a is not reachable
com.optinuity.c2o.util.C2OException: Unidentified UUID while resolving node
...
2022-05-03 06:47:55,132 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [_autoTPRecovery] Agent with id : 411c7fb7-c140-416e-8901-922cd73c69d3 is not reachable
com.optinuity.c2o.util.C2OException: Unidentified UUID while resolving node
...
2022-05-03 06:47:55,132 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [_autoTPRecovery] Agent with id : a8257bed-6cfd-4182-b5f9-bd912426eacf is not reachable
com.optinuity.c2o.util.C2OException: Unidentified UUID while resolving node
...
2022-05-03 06:49:55,179 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [_autoTPRecovery] Agent with id : 804c40c5-3b66-43fa-90b3-63278106155a is not reachable
com.optinuity.c2o.util.C2OException: Unidentified UUID while resolving node
...
2022-05-03 06:49:55,179 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [_autoTPRecovery] Agent with id : 411c7fb7-c140-416e-8901-922cd73c69d3 is not reachable
com.optinuity.c2o.util.C2OException: Unidentified UUID while resolving node
...
2022-05-03 06:49:55,179 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [_autoTPRecovery] Agent with id : a8257bed-6cfd-4182-b5f9-bd912426eacf is not reachable
com.optinuity.c2o.util.C2OException: Unidentified UUID while resolving node

Environment

Release : 4.3.X

Component : Process Automation

Cause

Those UUIDs were from agents that were previously deleted, but the UUIDs remained in the database.

Resolution

The UUID shown in the logs should not correspond to any of the agents which is of usage to the environment.  This can be confirmed by checking the UUID of the agent in property wrapper.java.additional.4=-Duuid  in c2oagtsvcw.conf file located at <Install_Loc>\PAMAgent\ 

If the UUID is related to an agent which being used, then that agent need to be started and made active to remove those error messages.

If the UUID does not correspond to any useful agent, then please follow the below steps for deleting the agent to remove those messages.

  1. Open ITPAM UI , Go to Configuration Browser and Lock the Domain.
  2. Under the Agents section, make sure to identify the agent which is corresponding to the UUID which  needs to be removed. This can be done by following Step 2 above.
  3. Delete the identified agent and Save the Configuration Browser.

Once the above steps are performed, after 5 mins, the error messages corresponding to that agent which is deleted will not appear in server logs.

Additional Information

Issue may also arise if there is a network configuration problem.  In one such case, a dedicated VLAN was created for the entire ITPAM ecosystem to address interoperability issues between the agents and orchestrator