LDAP user are not able to connect to Spectrum OneClick
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LDAP user are not able to connect to Spectrum OneClick

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Article ID: 240923

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

Some of the Spectrum users are not ablle to connect with Oneclick with their LDAP Username and Password.

Environment

Release : Any

Component : Spectrum OneClick with LDAP Configured

Cause

The following event is is seen:

"event_detail" : "Fri 29 Apr, 2022 _ 01:15:23 _ Lost contact with the specified LDAP server. Connection URL _ ldap://LDAP.server.net:389 Error Message _ javax.naming.CommunicationException: DomainDnsZones.LDAP.server.net:389 [Root exception is java.net.ConnectException: Connection refused (Connection refused)] (event [0x000cb004])

For this particular event, the error message received from the LDAP server is as follows:

"Error Message _ javax.naming.CommunicationException: DomainDnsZones.LDAP.server.net:389 [Root exception is java.net.ConnectException: Connection refused"

The Probable Cause associated with the alarm for this events states the following:

LDAP SERVER CANNOT BE REACHED

SYMPTOMS:

Attempts to login to OneClick through the specified LDAP server resulted in failure due to the LDAP service being unavailable.

PROBABLE CAUSES:

1) LDAP server is down.

2) The IP Address or Port specified for the LDAP server is incorrect.

RECOMMENDED ACTIONS:

1) Check status of LDAP server.

2) Confirm the specified IP Address and Port are correct.

Resolution

This error is coming from the LDAP server itself.

Reference the PROBABLE CAUSES and RECOMMENDED ACTIONS outlined in the event for resolution.