UIM 20.4 - OC/Reports shows 'CABI is not available or accessible' on Microsoft Edge only
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UIM 20.4 - OC/Reports shows 'CABI is not available or accessible' on Microsoft Edge only

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Article ID: 240632

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We can access the url https://<cabiserver>/cabijs correctly and see Jasperserver Reports Homepage with the Edge Chromium version 100.x.x.x without issues.

However, when accessing the OC/Reports Page We are getting an error as 'CABI is not available or accessible' when using the same Edge Chromium version 100.x.x.x

 

 

We can access OC/Reports Correctly with Chrome without any problem

 

What could be the issue? 

 

Environment

Release : 20.4

Component : UIM - CABI

Cause

Microsoft two-Steps identification enforced web Browser Security

Resolution

OC/Reports page can be reached out on machines in your system running chrome (where you have no enhanced security/double factor identity security step) 

On a laptop with Edge Chromium version 100.xxx The OC/Reports gives (CABI NOT FOUND). However, When accessing cabiserver/cabijs from the same session, after passing a security step cabi JS opens fine. 

After the CABIjs is open on a separate tab after accepting the security steps (sms/push ntf with code) cabijs is shown and if the OC tab is refreshed the OC/Reports is also shown. 

 

So the UIM and CABI are correctly configured and there is no Browser issue. However, on your laptop, you have a double factor security identity step that prevents the web page to open unless and until you insert a security code. 

This occurs for the OC itself when you open a new browser session. However, as the CABI is on a different server, when accessing OC/Reports it tries to open the cabijs URL, and it fails because the URL is not reachable unless the security protection allows the new server. 

 

The solution would be to disable these security steps for the OC and CABI URL, or include the CABI URL in the accepted URL's together with OC or, in any case, discuss this with your Windows/Network/Security team and discuss a possible solution to allow the browser to contact the CABI URL once the OC is already been verified.

If this is not possible you will need to live with the workaround, which is to open a separate tab with CABijs and accept the URL separately and then reload the OC page. 

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