Error on Webdriver monitor run in On-premise Station - OutOfDirectMemoryError
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Error on Webdriver monitor run in On-premise Station - OutOfDirectMemoryError

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Article ID: 240465

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Updated On:

Products

CA App Synthetic Monitor

Issue/Introduction

We have noticed the following errors reported against webdriver scripts running on OPMS stations

Monitor MYMONITOR1 error:5290: Script failed at step 3: no such element: Unable to locate element: {"method":"css selector","selector":"#ecm_widget_layout_NavigatorMainLayout_0_LoginPane_username"}

Monitor MYMONITOR2 Error: 5290: Script failed at step 8: no such element: Unable to locate element: {"method":"xpath","selector":"(.//*[normalize-space(text()) and normalize-space(.)='Assistant'])[1]/following::div[1]"}

This kind of error will solve after restart of station or webdriver agent.

 

 

 

Environment

Release : SAAS

Component : CA APP SYNTHETIC MONITOR (WATCHMOUSE)

Cause

This is caused by a memory leak in the webdriver code - the following type errors can be seen in the webdriver log

Mar 15, 2022 2:42:45 PM io.netty.channel.DefaultChannelPipeline onUnhandledInboundException WARNING: [ulxxpbromon01.adgr.net] 
An exceptionCaught() event was fired, and it reached at the tail of the pipeline. It usually means the last handler in the pipeline
did not handle the exception. io.netty.util.internal.OutOfDirectMemoryError: failed to allocate 16777216 byte(s) of direct memory
(used: 234881031, max: 239075328)

Resolution

The problem is addressed in OPMS 2022.02.008