NES unable to connect to NAC
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NES unable to connect to NAC

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Article ID: 240450

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio)

Issue/Introduction

We are having an issue where our NES is not able to connect to NAC. We already executed the actions described in knowledge base articles: 

but still encountering an issue. The error found in active_mq_nac.log are below 

2022-04-20 09:17:01,805 [triggerStartAsyncNetworkBridgeCreation: remoteBroker=tcp:///NES-IP:61616@48168, localBroker= vm://brokerNacServer#16934] INFO  (org.apache.activemq.network.DemandForwardingBridgeSupport:860) - Network connection between vm://brokerNacServer#16934 and tcp:///NES-IP:61616@48168 shutdown due to a local error: javax.jms.InvalidClientIDException: Broker: brokerNacServer - Client: Broker : NES-IP:61616_brokerNesServer_inbound_localhost already connected from vm://brokerNacServer#4
2022-04-20 09:17:01,809 [ActiveMQ BrokerService[brokerNacServer] Task-1673] INFO  (org.apache.activemq.network.DemandForwardingBridgeSupport:317) - localhost bridge to brokerNesServer stopped
2022-04-20 09:17:31,806 [ActiveMQ Task-1] INFO  (org.apache.activemq.network.DiscoveryNetworkConnector:120) - Establishing network connection from vm://brokerNacServer?network=true to tcp://NES-IP:61616
2022-04-20 09:17:31,811 [ActiveMQ VMTransport: vm://brokerNacServer#16939-1] WARN  (org.apache.activemq.broker.TransportConnection:770) - Failed to add Connection brokerNacServer->brokerNesServer-42272-1650361482382-3959:1
javax.jms.InvalidClientIDException: Broker: brokerNacServer - Client: Broker : NES-IP:61616_brokerNesServer_inbound_localhost already connected from vm://brokerNacServer#4
  at org.apache.activemq.broker.region.RegionBroker.addConnection(RegionBroker.java:246)​

Could you please assist us in finding the issue? 

Environment

Release : 6.X

Component : CA RELEASE AUTOMATION EXECUTION SERVER

Cause

The RA DB, table exec_servers maintains a unique entry for each Execution Server (ES) which get added when an ES is added via ASAP/ROC UI. However, during troubleshooting it was identified that there were duplicate entry for a specific execution server having trouble connecting, leading to the issue.

Query to validate execution servers entries in exec_servers table(SQL/ORACLE)

select * from exec_servers where name like '%EXEC_SERVER%';

Resolution

  •  Clean the corrupted data entry from DB using below query where timestamp for one of entry is 0
    • Query(ORACLE/SQL): delete from exec_servers where es_id=<IDENTIFIED_ID_OF_ES_WANT_TO_REMOVE>;
  • Stop the NAC & NES services, cleaned activemq-data\nac\LevelDB and activemq-data\nes\LevelDB directories and start the NAC & NES server.