Document Search ReIndexing
search cancel

Document Search ReIndexing

book

Article ID: 240410

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

In the user interface the following error is seen when attempting to upload an attachment:

SRCH-02001: Error while retrieving search contents. Contact your system administrator.

The logs show an error like:

ERROR 2022-04-27 06:24:42,490 [http-nio-8080-exec-280] niku.search (clarity:admin:19542321__9F7A1723-B1B4-40EC-B752-59AD877184F8:itl.changeObjectUpdate) LuceneSearchEngine.addFileToIndex: IO problem while adding to index org.apache.lucene.store.LockObtainFailedException: Lock obtain timed out: SimpleFSLock@clarity/nspiderfile/write.lock at org.apache.lucene.store.Lock.obtain(Lock.java:85)

Environment

Release : Any

Cause

Document Search Reindexing may be needed in cases with problems with attachments, the write.lock and similar.

Resolution

1.    Connect to properties.xml or CSA
2.    Set useSynchronousIndexing="false" - in CSA turn off Synchronous Indexing
3.    Search for and delete any files that end in write.lock on your app server(s).
They will look something like this:
lucene-62db5567fbeaae16396e79fb8fe42895-write.lock
4.    Restart the services
5.    Delete the nspider and nspiderfile folders from the file server  
6.    Log into the app server as someone who has full control of the filestore folders including the ability to create new folders/files like the nspiderfiles folders 
7.    Run the "admin search recreate-index-data" command 
8.    Run the "admin search recreate-index-files" command

When this has completed, turn on synchronous indexing or restart the "Index contents and documents" job.

***IMPORTANT: Please perform the activity after-hours, as it is very resource-intensive and could impact performance and ensure to stop all the clarity services before performing the steps. For very large filestores, please don't run the command's without contacting Broadcom Support***