Unable to run a repair on ITMS. Failing on TelemetryPatch.msi
search cancel

Unable to run a repair on ITMS. Failing on TelemetryPatch.msi

book

Article ID: 240398

calendar_today

Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

The customer is trying to run a repair on his currently installed ITMS implementation. SIM (Symantec Installation Manager) starts the repair but then fails. The SIM logs show the following entries:

Entry 1:

Repairing Package F:\Program Files\Altiris\Symantec Installation Manager\TelemetryPatch.msi
-----------------------------------------------------------------------------------------------------
Date: 4/26/2022 12:01:39 PM, Tick Count: 4594078 (01:16:34.0780000), Size: 366 B
Process: SymantecInstallationManager (9468), Thread ID: 28, Module: SymantecInstallationManager.exe
Priority: 4, Source: Symantec.Installation.Msi.RepairProduct

Entry 2:

RepairProduct for package F:\Program Files\Altiris\Symantec Installation Manager\TelemetryPatch.msi Failed with result InstallFailure
-----------------------------------------------------------------------------------------------------
Date: 4/26/2022 12:01:42 PM, Tick Count: 4597468 (01:16:37.4680000), Size: 411 B
Process: SymantecInstallationManager (9468), Thread ID: 28, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.Msi.ProcessMSIResult

Entry 3:

Repair failure while repairing Symantec Management Platform 8.5 RU4. Windows Installer API return code: 1603
-----------------------------------------------------------------------------------------------------
Date: 4/26/2022 12:14:36 PM, Tick Count: 5371390 (01:29:31.3900000), Size: 395 B
Process: SymantecInstallationManager (9468), Thread ID: 28, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.PerformInstall.RepairProducts

Entry 4:

Install/repair failure occurred.  Dequeuing any additional queued install sessions.
-----------------------------------------------------------------------------------------------------
Date: 4/26/2022 12:14:36 PM, Tick Count: 5371390 (01:29:31.3900000), Size: 411 B
Process: SymantecInstallationManager (9468), Thread ID: 28, Module: SymantecInstallationManager.exe
Priority: 2, Source: Symantec.Installation.Context.WizardProcess.InstallManager.performInstall_InstallFailedEvent

Environment

ITMS 8.5, 8.6

Cause

Bad MSI reference. It could be a previous bad MSI installation or the actual MSI is not longer present.

Resolution

Try the following:

1. Collect a Support Package (See "What information should I collect when troubleshooting Symantec Installation Manager 8.x/ (SIM 8.x)?"  (KB 181599)): 

Create a support package:

1. Log on to the computer where you installed the IT Management Suite solutions
as an administrator.
2. On the computer, start the Symantec Installation Manager.
3. On the Installed Products page, click Settings.
4. In the Settings dialog box, click Create support package.
5. To access the support package, in the dialog box that appears, select the Open
containing folder check box, and then click OK.

Alternatively, you can navigate to the following location on the computer to
view the support package files:
C:\Program Files\Altiris\Symantec Installation Manager\Support

and look at the Repair Logs usually found with the files collected by the Support Package (usually under Logs\RepairLogs from the extracted zip file) or look at the following location on the SMP Server:
C:\ProgramData\Symantec\SMP\Logs\RepairLogs

2. In this particular scenario, look at the "TelemetryPatch.msi_Repair.log". It may say something like this:

MSI (s) (60:1C) [13:44:29:655]: SOURCEMGMT: Trying source F:\Program Files\Altiris\Symantec Installation Manager\.
MSI (s) (60:1C) [13:44:29:655]: Note: 1: 2203 2: F:\Program Files\Altiris\Symantec Installation Manager\TelemetryPatch.msi 3: -2147287038 
MSI (s) (60:1C) [13:44:29:655]: SOURCEMGMT: Source is invalid due to missing/inaccessible package.
MSI (s) (60:1C) [13:44:29:655]: Note: 1: 1706 2: -2147483647 3: TelemetryPatch.msi 
MSI (s) (60:1C) [13:44:29:655]: SOURCEMGMT: Processing net source list.
MSI (s) (60:1C) [13:44:29:656]: Note: 1: 1706 2: -2147483647 3: TelemetryPatch.msi 
MSI (s) (60:1C) [13:44:29:656]: SOURCEMGMT: Processing media source list.
MSI (s) (60:1C) [13:44:29:663]: Note: 1: 2203 2:  3: -2147287037 
MSI (s) (60:1C) [13:44:29:663]: SOURCEMGMT: Source is invalid due to missing/inaccessible package.
MSI (s) (60:1C) [13:44:29:663]: Note: 1: 1706 2: -2147483647 3: TelemetryPatch.msi 
MSI (s) (60:1C) [13:44:29:663]: SOURCEMGMT: Processing URL source list.
MSI (s) (60:1C) [13:44:29:664]: Note: 1: 1402 2: UNKNOWN\URL 3: 2 
MSI (s) (60:1C) [13:44:29:664]: Note: 1: 1706 2: -2147483647 3: TelemetryPatch.msi 
MSI (s) (60:1C) [13:44:29:664]: Note: 1: 1706 2:  3: TelemetryPatch.msi 
MSI (s) (60:1C) [13:44:29:664]: SOURCEMGMT: Failed to resolve source
MSI (s) (60:1C) [13:44:29:664]: Note: 1: 2205 2:  3: Error 
MSI (s) (60:1C) [13:44:29:664]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1706 
MSI (s) (60:1C) [13:44:29:664]: Note: 1: 2205 2:  3: Error 
MSI (s) (60:1C) [13:44:29:664]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709 
MSI (s) (60:1C) [13:44:29:664]: Product: Symantec Telemetry Patch -- Error 1706. An installation package for the product Symantec Telemetry Patch cannot be found. Try the installation again using a valid copy of the installation package 'TelemetryPatch.msi'.

MSI (s) (60:1C) [13:44:29:682]: Note: 1: 2265 2:  3: -2147287035 
MSI (s) (60:1C) [13:44:29:683]: User policy value 'DisableRollback' is 0
MSI (s) (60:1C) [13:44:29:684]: Machine policy value 'DisableRollback' is 0
Action ended 13:44:29: InstallFinalize. Return value 3.

3. If you look at the path mentioned in the MSI Repair log (in this example, F:\Program Files\Altiris\Symantec Installation Manager\TelemetryPatch.msi), if you tried to repair the affected MSI, it may say "this action is only valid for products that are currently installed". Then if you tried to install it, it may state that "another version of the product is already installed and this version cannot continue". Also, if you tried to uninstall it and it said the same thing about "another version already is installed", then the best option would be to remove the MSI references from the MSI repository on the server.
You can try the free tool called "UninstallView.exe" from Nirsoft (https://www.nirsoft.net/utils/uninstall_view.html) or use the following "MicrosoftProgram_Install_and_Uninstall.meta.diagcab" Microsoft tool to remove the MSI reference:

Fix problems that block programs from being installed or removed


4. After the affected MSI reference is removed, you can try to install the MSI manually or just try to run the Repair process again within SIM.