Patch Management for Linux - client does not appear in compliance reports
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Patch Management for Linux - client does not appear in compliance reports

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Article ID: 240249

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Updated On:

Products

Server Management Suite IT Management Suite Patch Management Solution

Issue/Introduction

You have noticed that some of your Linux client have stopped receiving update policies and does not appear in your compliance reports.

Environment

ITMS 8.5, 8.6, 8.7

Cause

One of the criteria to evaluate a client machine is its Linux OS dataclass (you can check that by opening Resource Manager for that client machine).

Missing information in this dataclass will stop client from receiving updates:

This problem may occur if computer is deleted from the SMP console and while computer restores itself back during next basic inventory, client will not report this dataclass anymore, unless reinstalled.

Resolution

Try the following on your SMP Server Console:

  1. Open the following page on your browser:
    https://server_name/Altiris/InventoryRuleManagement/Policies/InventoryRulePolicyPage.aspx?ItemGuid=e122eb63-0686-4380-a355-1e94eb4ac53b

  2. Change option under Report Results to "Always"



  3. Save changes

Next time a client machine will report desired inventory back to server.