Jobs fail with the error "user ADMIN not authorized to use agent group xxxx"
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Jobs fail with the error "user ADMIN not authorized to use agent group xxxx"

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Article ID: 240148

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Updated On:

Products

CA Workload Automation DE CA Workload Automation DE - Scheduler (dSeries)

Issue/Introduction

Post upgrade from 12.2 to 12.3/12.4, the Jobs are failing with the following message

"user ADMIN not authorized to use agent group xxxxxx"

Environment

Component : Workload Automation DE

Cause

Compatibility Issue.

 

Resolution

Upgrade the Desktop Client to same version level and manually update the agentgroup permissions to allow for all groups.
  • If you are using AgentGroup, you must add the permissions for each AGENTGROUP manually. Otherwise, the jobs using AgentGroup will not run.
  • If you are using the latest Workload Automation DE Server version – 12.3/12.4 and lower version of Desktop Client or Web Client, it will not display the dashboard for the users with AGENTGROUP permission.

Additional Information