SiteMinder : Inplace upgrade error "Cannot upgrade from Policy Server  SP 0"
search cancel

SiteMinder : Inplace upgrade error "Cannot upgrade from Policy Server  SP 0"

book

Article ID: 240138

calendar_today

Updated On:

Products

SITEMINDER CA Single Sign On Agents (SiteMinder) CA Single Sign On Federation (SiteMinder) CA Single Sign On Secure Proxy Server (SiteMinder)

Issue/Introduction

During Siteminder 12.8.x  in-place upgrade, installer receives error:

===============================================================================

Cannot upgrade from Policy Server  SP 0

---------------------------------------

Policy Server  SP 0 is installed.  Upgrades are supported from 4.51 SP05, 4.61

SP05, 5.0 SP01, 5.5 SP02, 6.0 and 12.0 .  Select 'OK' to exit installation.

===============================================================================

Environment

Release : 12.8.x

Component : SITEMINDER -POLICY SERVER

OS : Linux

Cause

If any non-root user account like smuser was used to install policy server originally. While upgradation the Policy server binaries for inplace upgrade checks the current version of Policy server using the file ".com.zerog.registry.xml"  and for some reason the contents or file missing at the user home location example : /home/smuser/.com.zerog.registry.xml file or has wrong content in this file.

Resolution

This can be resolved by following below two workaround solutions for Policy server installed using specific user.

1.  Check the .com.zerog.registry.xml under the user's home directory  example location : /home/smuser/.com.zerog.registry.xml exists and correct this file with appropriate product name and version details of the current running version..

2. Replace the existing  .com.zerog.registry.xml   from the location <siteminder_home>/install_config_info/ca-ps-uninstall/.com.zerog.registry.xml, but be sure to verify the content first before replacing.

Note : .com.zerog.registry.xml is a hidden file.