Error: "Device is not entitled to download Policy Services Database" on ProxySG, ISG Proxy, or Advanced Secure Gateway
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Error: "Device is not entitled to download Policy Services Database" on ProxySG, ISG Proxy, or Advanced Secure Gateway

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Article ID: 240116

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Updated On:

Products

ProxySG Software - SGOS ISG Proxy ASG-S200 ASG-S400 ASG-S500

Issue/Introduction

Receiving the error: "Device is not entitled to download Policy Services Database." when the Edge SWG (ProxySG) attempts to download the Policy Services Database file. 

Cause

Backend licensing issue.

Resolution

The policy services feature is available on all supported ProxySG appliances with a valid base license and available on SGOS 7.x systems. No additional subscription is required. 

 

See: Configure Policy Services

 

A potential solution to this issue is to force a full download of the policy services database:

  • Ensure access to the command-line interface (CLI) through the serial port console, an SSH connection, or a telnet connection
  • Obtain the appliance's enable password

Note: Force the full update only as directed by the Support Engineer. Perform the update during off-hours to have minimal effect on the end-users.

There are three steps involved in resolving this issue:

  1. Disabling policy services

  2. Purging the database

  3. Reenable policy services and view the status

 

  1. Disable policy services

    • > enable
    • ProxySG# config t
    • ProxySG#(config) policy-services
    • ProxySG#(config policy-services) disable
  2. Purge the previous database and force a new database to download

    • ProxySG#(config policy-services) purge
    • ProxySG#(config policy-services) download get-now force
  3. Enable policy services and view the status

    • ProxySG#(config policy-services) enable
    • ProxySG#(config policy-services) view
    • License Type:           Subscription
      Licensed Until:         Thu, 22 Sep 2022 00:00:00 UTC
      Service:                Enabled
      Download method:        Direct
      Last successful download:
        Time:                 Fri, 22 Apr 2022 18:51:15 UTC
        No download required.  Subscription is up to date
        Downloaded from:      https://subscription.es.bluecoat.com/defaultpolicy/database
        Version:              63433

If you still receive an error similar to:

Warning: This feature is currently disabled. To use the data being downloaded, the feature will need to be enabled.
Time: Thu, 21 Apr 2022 17:56:56 UTC
% Device is not entitled to download Policy Services Database.
Download URL:         https://subscription.es.bluecoat.com/defaultpolicy/database

The perform the following steps:

  1. Log into the support portal
  2. Go to "My Entitlements"
  3. Find the affected appliance by serial number then click on the "Licenses" icon.
  4. In the licensing webpage that opens click on "Download License button" to generate a new license and trigger an update of the records in the back end.
  5. Wait one-hour letting backend systems replicate before trying to re-sync the local database again.

If the issue still persists after applying the above steps, contact technical support including the serial number. The support engineer work with the backend licensing team for further investigation.