search cancel

"Warning: RPMDB altered outside of yum" error when reinstalling patch 292

book

Article ID: 240107

calendar_today

Updated On:

Products

Messaging Gateway

Issue/Introduction

If you need to reinstall patch 292 for some reason, you will see the following warning when the patch is reinstalled:

Warning: RPMDB altered outside of yum.
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
sms-appliance-release-10.7.5-4.noarch has missing requires of openssl = ('1', '1.0.2k', '21.el7_9')
sms-appliance-release-10.7.5-4.noarch has missing requires of openssl-libs = ('1', '1.0.2k', '21.el7_9')
  Installing : sms-appliance-patch-10.7.5-292.x86_64 

Cause

OpenSSL is being updated directly as part of patch 292.

Resolution

This is an expected warning due to the nature of the patch. This warning can be ignored.