caperfcenter_console.service will not start after upgrading
search cancel

caperfcenter_console.service will not start after upgrading

book

Article ID: 240086

calendar_today

Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

After upgrading from 21.2.7 to 21.2.9 yesterday in PC the console does not start.  We saw the following int he terminal

systemctl start caperfcenter_console
Job for caperfcenter_console.service failed because the control process exited with error code.
See "systemctl status caperfcenter_console.service" and "journalctl -xe" for details.

 

The following was in the PC wrapper log:

INFO   | jvm 5    | 2022/04/22 08:41:32 | # There is insufficient memory for the Java Runtime Environment to continue.
INFO   | jvm 5    | 2022/04/22 08:41:32 | # Native memory allocation (mmap) failed to map 433230831616 bytes for committing reserved memory.
INFO   | jvm 5    | 2022/04/22 08:41:32 | # An error report file with more information is saved as:
INFO   | jvm 5    | 2022/04/22 08:41:32 | # /opt/CA/PerformanceCenter/PC/bin/hs_err_pid117825.log
FATAL  | wrapper  | 2022/04/22 08:41:32 | There were 5 failed launches in a row, each lasting less than 300 seconds.  Giving up.
FATAL  | wrapper  | 2022/04/22 08:41:32 |   There may be a configuration problem: please check the logs.
STATUS | wrapper  | 2022/04/22 08:41:32 | <-- Wrapper Stopped

Environment

Dx NetOps Performance Management any version

Cause

The memory in /opt/CA/PerformanceCenter/PC/conf/wrapper.conf was misconfigured

Resolution

Update /opt/CA/PerformanceCenter/PC/conf/wrapper.conf and change wrapper.java.maxmemory so that the value is 1/6 of total memory then restart the service