Unable to Start WebApp on OC/SRM Server after Upgrade
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Unable to Start WebApp on OC/SRM Server after Upgrade

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Article ID: 240077

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Updated On:

Products

Spectrum Network Observability

Issue/Introduction

Unable to start up the WebApp with the following error shown; 

"Request processing failed.  Please refer the tomcat log for more details.  ...Not able to reach OneClick Webapp. "

Looking at the Spectrum OneClick (tomcat) log file ($SPECROOT/tomcat/logs/catalina.out or stout.log in Windows), the following entry is seen:

"javax.net.ssl.SSLException: Unsupported or unrecognized SSL message"

 

Environment

DX NetOps Spectrum Release 21.2.x or later

Cause

The following error is logged in the $SPECROOT/webtomcat/bin/logs/webswing.log file:

Caused by: javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

Resolution

  1. Edit the $SPECROOT/webtomcat/bin/webswing-admin.properties file and changed to full path:

    webswing.server.websocket.truststore = /opt/CA/Spectrum/custom/keystore/cacerts

    Restart the WebTomcat service.

  2. If the same error is still in the  $SPECROOT/webtomcat/bin/logs/webswing.log file,

    Open the WebSwing page - https://<OneClick_host>:9443/spectrum

    Login: spectrum/spectrum

    Locate the JVM Arguments section.

    Edit it and added the following at the end (-Djavax.net.ssl.trustStore=${SPECROOT}/custom/keystore/cacerts -Djavax.net.ssl.trustStorePassword=changeit):

    -Djavax.net.ssl.trustStore=/opt/CA/Spectrum/custom/keystore/cacerts -Djavax.net.ssl.trustStorePassword=changeit

  3. Save the changes. Relaunch the OneClick WebApp.

Additional Information

This same problem can also be seen in a new Spectrum install when using a Self Signed Certificate.  The same resolution steps apply here as well.