search cancel

Agent version 6.6 compatibility with 6.7

book

Article ID: 239954

calendar_today

Updated On:

Products

CA Release Automation - Release Operations Center (Nolio)

Issue/Introduction

We are planning to upgrade our Environment to latest version of 6.7 in coming months but in our cases some of the agents will be on the lower version 6.6.0.9640 or higher. 

We want to validate if the same will work if upgrade our NAC and NES's to 6.7

Please help us to validate and share your recommendation and findings so that we can plan accordingly.

Environment

Release : 6.7, 6.6

Component : CA RELEASE AUTOMATION AGENT

Resolution

The NolioAgent 6.6.0.X will work with RA 6.7.0.81 as the version of Java from 6.6.X is 1.8.*.*

Java version in 6.6.0.x agents

NolioAgent669640]# ./jre/bin/java -version
java version "1.8.0_162"
Java(TM) SE Runtime Environment (build 1.8.0_162-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.162-b12, mixed mode)

 

Note: If you apply cumulative 6.7.4 or higher over 6.7.0.b81(GA) you need to upgrade all agents to minimum 6.7.4 in order to use SSL communication due to below mentioned reason. Please refer 6.7.4 Release notes for more details

When using new AES encrypted Keystore passwords, configurations (for example, Agents) with versions prior to 6.7.4 will be unable to use AES. To use AES encrypted passwords, the exemplary Agents mentioned before have to be upgraded to V6.7.4.

Additional Information

Related Articles

Agent version 5.5.2.191 compatibility with NAC/NES version 6.7