search cancel

Unable to install DLP 15.8 on a Linux server

book

Article ID: 239929

calendar_today

Updated On:

Products

Data Loss Prevention Enterprise Suite Data Loss Prevention Enforce

Issue/Introduction

Attempting to install a DLP 15.8 Enforce server on Linux, running the ./install.sh -t enforce command, the following error is seen:

/USUNDLPDEVAP001/Symantec/DataLossPrevention/EnforceServer/15.8.00000/Protect/install/GenerateEncryptedPropertiesFilesEncryptionKey: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /USUNDLPDEVAP001/Symantec/DataLossPrevention/EnforceServer/15.8.00000/Protect/install/GenerateEncryptedPropertiesFilesEncryptionKey)

/USUNDLPDEVAP001/Symantec/DataLossPrevention/EnforceServer/15.8.00000/Protect/install/WriteEnforceServerRelocations: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /USUNDLPDEVAP001/Symantec/DataLossPrevention/EnforceServer/15.8.00000/Protect/install/WriteEnforceServerRelocations)

Cause

The file /etc/ld.so.conf  has /usr/lib and /usr/lib64 that are not necessary

Environment

Release : 15.8

Component : Enforce

Resolution

Modify  /etc/ld.so.conf  and remove  /usr/lib and /usr/lib64

It should only have ld.so.conf.d/*

Reinstall DLP 15.8