search cancel

EOL/Obsolete Software: Node.js 6.x Detected

book

Article ID: 239910

calendar_today

Updated On:

Products

CA Directory

Issue/Introduction

Running a vulnerability scan on your Symantec Directory Manager host, may report on an EOL/Obsolete Software: Node.js 6.X Detected.

e.g.
EOL/Obsolete Software: Node.js 6.x Detected in "Install Location /opt/CA/Directory/management-ui/node.js/bin/node 6.14.4"

Yon have also review 'relnotes' under $DXHOME/../ folder to confirm the version of NodeJS is 6.14.4.

Resolution

The above mentioned EOL/Obsolete NodeJS version was part of Directory Manager 14.1.01 version which has also been marked as EOS (End Of Service).
Soution would be to upgrade to later version of Directory Manager where:

Directory 14.1.02 is packaged with NodeJS version 12.16.3
&
Directory 14.1.03 is packaged with NodeJS version 14.17.6