CORBA Object does not exist error in NCM when running a configuration capture
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CORBA Object does not exist error in NCM when running a configuration capture

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Article ID: 239902

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Updated On:

Products

Spectrum Network Observability

Issue/Introduction

The customer is getting the following error when trying to to capture a Host Config using NCM:

Environment

All supported Spectrum Releases.

Cause

This might occurs due Insufficient memory configuration for the ncmservice.

Customers have also reported that Juniper devices with rfc-compliant & yang-compliant configured may thrown this error message.

Resolution

- Log into the SpectroSERVER system as the user that owns the Spectrum installation

- Make a backup of the $SPECROOT/lib/SDPM/partslist/NCMSERV.idb file

- Edit the $SPECROOT/lib/SDPM/partslist/NCMSERV.idb file

- In the line at the bottom of the file that starts with "ARGV", look for the the following:

-Xmx1024M 

Change the above to read as follows:

-Xmx4096M 

- Save the change

You will need to arraign for a time to shutdown the SpectroSERVER processes gracefully and then reboot the system for the change to take affect.

For Juniper devices with rfc-compliant & yang-compliant configured, after removing those configurations the problem is no longer observed. The configuration in the device will look as follow:

- netconf rfc-compliant
- netconf yang-compliant