Error using migration xpress tool - The system cannot find the path specified
search cancel

Error using migration xpress tool - The system cannot find the path specified

book

Article ID: 239887

calendar_today

Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

When I run Migration Xpress tool I get error below in log.

13:53:29.840 [XNIO-2 task-25] INFO com.ca.tools.im.analyzer.dto.ImManagementConsole.163 - Loading RolesDef XML from IM Managemnt Console
13:53:29.873 [XNIO-2 task-25] INFO com.ca.tools.im.analyzer.dto.ImManagementConsole.570 - Exporting IM RolesDef XML from the IM Management Console
13:54:09.650 [XNIO-2 task-25] ERROR io.undertow.servlet.api.LoggingExceptionHandler.80 - UT005023: Exception handling request to /analyzer/envxml/load
org.springframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.Exception: Failed to load IM RolesDef XML: Failed to export the IM RolesDef XML: Failed to save the RolesDef XML into a file on the server's disk: data\RoleDefinitions-cache-SOURCE.xml (The system cannot find the path specified)

Also:

Caused by: java.lang.Exception: Failed to export the User Store XML: Failed to save the User Store XML into a file on the server's disk: data\UserStore-cache-SOURCE.xml (The system cannot find the path specified)
      

Environment

Release : 14.3, 14.4

Component :

Cause

The assumption in the code is that the scripts will be run from the default location using path execution.

 

 

Resolution

Migration Xpress needs to be run from its main folder/directory which contains bin, conf, data, jdbc, lib folders.

Please follow:

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-suite/14-4/virtual-appliance/Migrating-Virtual-Appliance/Standalone-or-Virtual-Appliance-Migration-Using-Migration-Xpress/Migration-Process-Workflow/Deploy-Migration-Xpress.html