ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Console service doesn't start after 21.2.8 upgrade

book

Article ID: 239698

calendar_today

Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

I upgraded the Dev Platform form 20.2.1 to 21.2.8 and it was nearly perfect, but the Console service on the Console server won't start.  It appears to be a communication configuration issue between the DA and Console server.  DM/EM/SSO all start without issue, and I'm unable to get into SsoConfig. 

Cannot connect the to DX NetOps SSO Web Service.
Check if DX NetOps is running and retry.

[[email protected]_hostname PerformanceCenter]# service caperfcenter_console status
Redirecting to /bin/systemctl status caperfcenter_console.service
● caperfcenter_console.service - Performance Center Console
   Loaded: loaded (/etc/systemd/system/caperfcenter_console.service; enabled; vendor preset: disabled)
   Active: failed (Result: timeout) since Mon 2022-04-18 07:21:40 EDT; 35min ago
  Process: 24183 ExecStart=/CA/PerformanceCenter/PC/bin/caperfcenter_console start sysd (code=killed, signal=TERM)

Apr 18 07:16:40 PC_hostname systemd[1]: Starting Performance Center Console...
Apr 18 07:16:40 PC_hostname caperfcenter_console[24183]: /usr/bin/wget
Apr 18 07:21:40 PC_hostname systemd[1]: caperfcenter_console.service start operation timed out. Terminating.
Apr 18 07:21:40 PC_hostname systemd[1]: Failed to start Performance Center Console.
Apr 18 07:21:40 PC_hostname systemd[1]: Unit caperfcenter_console.service entered failed state.
Apr 18 07:21:40 PC_hostname systemd[1]: caperfcenter_console.service failed.

Cause

There is a known issue in 21.2.8, the 'PDF.Max.Concurrent' cannot be increased beyond 5.

Fixed in 21.2.9 (general table setting), and later in 21.2.10 (fixes dm.properties > 5).

The DM logs are very sparse. There is barely any logging in them...

Looking at the largest DM wrapper, the last restart was at:

STATUS | wrapper  | 2022/04/14 16:52:48 | Launching a JVM...and soon after...INFO   | jvm 1    | 2022/04/14 16:53:05 | Caused by: java.lang.IllegalArgumentExceptionINFO   | jvm 1    | 2022/04/14 16:53:05 | 	at java.util.concurrent.ThreadPoolExecutor.setCorePoolSize(Unknown Source) ~[?:?]INFO   | jvm 1    | 2022/04/14 16:53:05 | 	at com.ca.im.portal.dm.scheduling.email.EmailJobScheduler.configureExecutorPoolSize(EmailJobScheduler.java:200) ~[?:?]

Also seeing:

INFO   | jvm 1    | 2022/04/14 16:53:05 |       | Application does not have write permission for /CA/PerformanceCenter/DM/repository directory.

So the dm.properties is fine, meaning the general table entries are bad...
looking at general.txt..

| PDF.Full.Max.Concurrent                      | 1                                                                                                                                               
| PDF.Max.Concurrent                           | 40                                            

Environment

Release : 21.2

Component : Performance Management Portal Web UI

Resolution

Please run this MySQL syntax:

replace into netqosportal.general values ('PDF.Max.Concurrent', '5');

Then re-start the DM and PC services.